Kawasaki Z125 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey everyone! So, at the start of the year (around March 2020), I spent a gooooood lil bit of change on baby Z and got fuel system flushed, spark plugs changed, new ignition switch, new battery, as well as a new stator and rectifier. I had the bike back for 2 weeks when, one morning, I was on the way to work and was topping out right at 65mph. I felt a major power drop and baby Z would only max out at around 54mph. When coming to the next red light, the bike just died once stopped and no throttle. The engine would turn, but not start. I rolled to the nearest gas station and pop-started her, she roared to life with a pretty unpleasant sound rattling from what sounded like the lower left engine area. I let off throttle and dead again. Was so mad that i let it sit for quite some time and decided now that I want to fix her myself. Has anyone had this issue or maybe know what it could be?
 

·
Super Moderator
Joined
·
1,893 Posts
a new stator and rectifier. pretty unpleasant sound rattling from what sounded like the lower left engine area.
Because it was just replaced, Sounds like remove side cover and check stator and crankshaft sensor for any fasteners might have came loose
And also starting to see generator bolts coming loose and chewing up stators, But mostly from those that removed and reassembled the generator for starter gears or starter clutch repairs.

119183204_3596638947035322_6340024239346786768_n.jpg
 
1 - 2 of 2 Posts
Top