Kawasaki Z125 Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
165 Posts
Discussion Starter #1
i just finished my clutch job on my z125. first all you dont have to reuse 2 of the plates like others have done you can use all the plates from your kit.
the part numbers are

tbparts #1035 (KAWASAKI KLX110 KLX110L Heavy Duty Clutch Kit Plates Springs 2002-2016)



this kit comes with the hd springs and they are very stiff but if you like softer springs go with the bbr springs (410-KLX-1105)


now for my review no slip anywhere very consistent feel and grab so for those of you who want a clutch and dont know what to get here is what i used but im sure any klx 110 kit will work just fine aswell and lik ei said you dont need to reuse the old junk. enjoy
 

·
Registered
Joined
·
54 Posts
How much ( if any ) did it change your friction point location on clutch release? That is my main gripe with the Z125. I wish the **** thing would engage at least 1/2 way out.
 

·
Registered
Joined
·
165 Posts
Discussion Starter #9
How much ( if any ) did it change your friction point location on clutch release? That is my main gripe with the Z125. I wish the **** thing would engage at least 1/2 way out.
it depends on the springs your using on how hard its gonna grab. on mine at first it was right off the bar and as it set in it ended up being a little before half way but the engagment is allot firmer and will give better feedback. i hope this helps you.
 

·
Registered
Joined
·
54 Posts
it depends on the springs your using on how hard its gonna grab. on mine at first it was right off the bar and as it set in it ended up being a little before half way but the engagment is allot firmer and will give better feedback. i hope this helps you.


Great news ! I may have to do this. I cannot stand that late engagement from the stock clutch. Thanks for the feedback !
 

·
Registered
Joined
·
27 Posts
Alright guys I got a question. I bought the clutch kit that you linked, install went smooth and everything went back together like it should. The clutch feels much better than the stock one for sure. But after about 15 miles I pulled the lever and it would NOT pull all the way and I could not change gears. It felt like something was jamming up inside but after a minute it pulled nice and smooth no problems whatsoever. It did this 2 more times on about a 50 mile ride. Any ideas on what could be causing this?
 

·
Registered
Joined
·
165 Posts
Discussion Starter #17
Alright guys I got a question. I bought the clutch kit that you linked, install went smooth and everything went back together like it should. The clutch feels much better than the stock one for sure. But after about 15 miles I pulled the lever and it would NOT pull all the way and I could not change gears. It felt like something was jamming up inside but after a minute it pulled nice and smooth no problems whatsoever. It did this 2 more times on about a 50 mile ride. Any ideas on what could be causing this?
i am not really sure i would say take everything apart and make sure everything is in the correct order and re assemble if anything is damaged replace it. somthing has to be loose or jammed up.
 

·
Registered
Joined
·
92 Posts
Was there a tiny ball which may have fallen out I know it exists on other bikes I have not had this bike apart yet
 

·
Registered
Joined
·
326 Posts
My bike from day one has had a clutch whine. It's in the clutch... as you hold it still, slip the clutch and rev the engine, the whine changes with the revs. Doing a warranty claim now with Kawi to see what they say out of curiosity. If they say, replace the clutch pack, I'll just have a new OE pack. Just ordered my HD kit, let's see how this goes.
 
1 - 20 of 24 Posts
Top