Kawasaki Z125 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hey, guys i just wanted to upload some pics from my bazzaz install for the z-fi. the install took roughly about 45min to 1hour. i hope this helps you guys out.

the FIRST image is for the tps taping it will be a solid yellow with a white tracer, SECOND is the connector for the speed sensor, THIRD is for fuel injector, and finally the last one is for the placement of the ecm and when to tap for power and ground. Their should be more connectors on the left side of the bike near the engine, with a rubber cover and thats where the rest will be. Also the ECM comes blank so dont forget to run the base map in it.

happy ridings,
tim :grin2:







 

·
Registered
Joined
·
131 Posts
hey, guys i just wanted to upload some pics from my bazzaz install for the z-fi. the install took roughly about 45min to 1hour. i hope this helps you guys out.

the FIRST image is for the tps taping it will be a solid yellow with a white tracer, SECOND is the connector for the speed sensor, THIRD is for fuel injector, and finally the last one is for the placement of the ecm and when to tap for power and ground. Their should be more connectors on the left side of the bike near the engine, with a rubber cover and thats where the rest will be. Also the ECM comes blank so dont forget to run the base map in it.

happy ridings,
tim :grin2:







Is there a pdf of instructions available? And I thought they shipped with 2 pre set maps?
 
1 - 2 of 2 Posts
Top