Kawasaki Z125 Forum banner

1 - 7 of 7 Posts

·
Registered
2021 kawasaki z125 pro
Joined
·
4 Posts
Discussion Starter · #1 ·
Just bought a 2021 z125 a week ago put around 120 miles on it, got on it earlier today maybe rode five miles cut the engine off and went to start it a cpl minutes later and it won't turn over not even trying to push start wld work. Got it back home sadly in the back of a truck, CEL codes read 5 1. I can most likely take it back to the dealer but their not open for a few days just trying to get some ideas.
 

·
Super Moderator
Joined
·
2,018 Posts
I see a lot of bikes get that code and they replace the coil, And that Wasn't It.

If you a multi meter test the coil first
Service manual page 432
Pic with checking through the cap

To Avoid a lot of back and forth questions, If you can post a video of the meter unit from the key-off to trying to start and need to hear fuel pump cycle, I can rule out quite a few things right off
 

Attachments

·
Registered
Joined
·
398 Posts
Welcome to the forums. That's the second person with problems on a brand new bike in the same month. As you still have a warranty its just better they deal with it.
 

·
Super Moderator
Joined
·
400 Posts
I think PDI's are falling off the map or being rushed during COVID. Seems to be happening more and more often.

Just to clarify, PDI stands for Pre Delivery Inspection but is kind of a misleading term. It's basically the assembly and run in process between the crate and the customer taking it home. Lots of people think you put gas in it, install the mirrors, and you're done. It's quite a bit more involved than that and I think that's where the "new bike" issues are coming from.
 

·
Registered
2021 kawasaki z125 pro
Joined
·
4 Posts
Discussion Starter · #5 ·
New video by Scotty62187
I am taking it back to the dealer but their not open till tomorrow and I have to wait till I get off work, there's nothing I cld have done within a week to have it do this so I'm thinking its something they did or didn't do
 

·
Registered
2021 kawasaki z125 pro
Joined
·
4 Posts
Discussion Starter · #6 ·
Update, the dealership finally looked into and their saying its a faulty ECU so they ordered a new one which can take up to two weeks for delivery...
 

·
Registered
Joined
·
398 Posts
2 weeks.. at least they figured it out though. Hopefully you get it back sooner than later
 
1 - 7 of 7 Posts
Top