Kawasaki Z125 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
So I was up at both Small Bore events (Barber/Townsend) and throughout the trip up there riding, the speedometer would either work intermittently or not at all.

The only two things I've done shortly before those events/riding up there was remove the chain to clean it and reinstall and I also added fuel scent additive to the gas tank. I have used this fuel scent (grape) in both this motorcycle as well as my Yamaha Zuma and KTM dirtbike with no issues so I doubt the fuel scent created the problem.

I probably rode about 500 miles between those two events with only about 275 of those miles being recorded as the speedometer only worked intermittently as I said above.

Sometimes when it was working, I would get to a destination and turn off the motorcycle and when I started it to ride again, it either didn't work at all or would come on for either a short time or until I turned the motorcycle off again.

Since I've returned home back to Florida, the speedometer hasn't been working at all.

One other thing of note is that it does have a Bazzaz tuner on this Z so not sure if this would affect anything either. It's been on the motorcycle for close to 2000 miles without issue.

This all being said, can anyone point me in a direction on what to check in hopes to resolve this issue?
 

·
Super Moderator
Joined
·
2,206 Posts
If your speed shows "0" mph regardless of the speed you going or if you have CEL code 24 its the speed sensor.
If its intermittent check the connector as shown but thinking it should have thrown the code 24 ?

Product Automotive tire Automotive exhaust Motor vehicle Automotive fuel system
 
1 - 3 of 3 Posts
Top