Kawasaki Z125 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hello,

I have a quick question on the comp s exhaust, do you use the old manifold gasket from the stock exhaust? Mine runs weird when I put the gasket in and makes a weird noise between 5000-6000 rpms. Just want to know if I should use the old buy a new or eliminate it.

Thanks for the help!
 

·
Registered
Joined
·
347 Posts
when exhaust is cold
start the bike, cover the exhaust outlet with your hand

if you hear air blowing out from the front gasket the gasket is bad

if its really quiet and you hear nothing the gasket is good


noises you may be hearing could be something vibrating
possibly the exhaust

maybe make sure nothing is touching anything or its all tight



also look at your rear pegs, they bounce around when riding could always put some tape on them or lock down and do a test ride
 

·
Registered
Joined
·
325 Posts
I rode my z around the neighborhood without my helmet the other day and noticed that the license plate vibrated loudly at certain rpm on the tail tidy I had installed. Never noticed that with my helmet on. Piece of foam didn't fix the noise.
 

·
Registered
Joined
·
440 Posts
I rode my z around the neighborhood without my helmet the other day and noticed that the license plate vibrated loudly at certain rpm on the tail tidy I had installed. Never noticed that with my helmet on. Piece of foam didn't fix the noise.
Which tail tidy do you have ?? Have you tried seeing if everything was tight ?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
i used the old gasket did the cover test mike mentioned, all runs great!
Mine is really crushed I am just going to replace it. $3.00 cant really complain. But **** that exhaust screams haha
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
oh yeah dat muff is ridic!
I am on my way to having hearing aids! I got it because of your video! but videos don't do it justice. Makes my ears cry blood!
 

·
Registered
Joined
·
325 Posts
Which tail tidy do you have ?? Have you tried seeing if everything was tight ?
I have the Mnnthbx tidy. Well designed imo and yeah, it was tight. Just the right rpm set up a vibe that caused the plate to vibrate against the mount. I used some foam leftover from a shorai battery that I stuck behind the plate and no more noise.
 
1 - 10 of 10 Posts
Top