Kawasaki Z125 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
131 Posts
Discussion Starter #1
Hey guys, just needed a little advice on how to clear the efi light. I was installing Bazzaz and got a tps sensor failure upon completing. It was my doing as I had left the clip undone after splicing the tps, turned re bike on which obviously gave it the error. I have verified everything is working correctly, even better now with the FC but I need to get the light off. Any thoughts? Is it the same As other Kawasaki FI bikes? Any help is appreciated. And be nice, I know I was dumb lol.
 

·
Registered
Joined
·
34 Posts
Ouch... looks like the same manual clearing procedure as the 5th gen (2016+) ZX-10R... Eek.

1) Can be cleared with a KDS 3 at the stealership

Otherwise there is a manual process

1. Turn ignition on and start the engine
2. Keep the idling speed more than 30 seconds
3. Run the vehicle more than 5 minutes at a speed of 40 km/h (25mph) or more. Be sure to keep the engine running during procedures 2 and 3 for more than 10 minutes total.
4. Turn the ignition switch off.
5. Repeat the above procedures 3 times.
6. Start the engine and check that the yellow engine warning indicator light goes off.

We can clear these codes in Woolich Racing software on the ZX-10R, unfortunately that doesn't help you here. What you'll have to do is figure out what the code is for, fix it, then pretty much ride the bike over and over and after you've done the above 3 times, the code will clear if the issue has been fixed.
 

·
Registered
Joined
·
131 Posts
Discussion Starter #3
I ended up taking it to my brothers work. He works for a dealership and he turned it off on their machine. All is well other than the big screw I got in the tire on the way home :/ o well, now my wife can't whine when I buy a new set. I wanted to go a bit wider anyways lol
 
1 - 3 of 3 Posts
Top