Kawasaki Z125 Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey guys, have a question i put a musari exhaust on my bike, everything else is stock, and when im crusing i look down and the header pipe is glowing red, obviously it is lean, do i need a fuel controler just for a exhaust?? I see other people with intake and exhaust and they dont have this problem, any input helps thanks guys
 

·
Registered
Joined
·
143 Posts
A controller would probably help with the glowing and give some small power gains, but unless your performance is suffering, it's really not vital that you get one. More power is always nice, but the question is how much are you willing to spend for small gains?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I just put the stock exhaust on and still same thing, getting hot not as bad but can still see it getting red, if its normal ill leave it, im just wondering if its not normal and if it will hurt anything in the long run, thanks man
 

·
Registered
Joined
·
143 Posts
While I have never noticed it, I've heard others mention theirs doing it. I don't ride much at night, so mine might do it and I just never noticed. Being an air cooled motor, stuff is going to get hot. My air cooled Hypermotard throws off insane amounts of heat sometimes. I've never felt the Z125 come close to the heat that the Hyper puts out.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
I appreciate the input guys, the plug didnt look lean eather, i guess ill throw the musari exhaust back on and just ride it till the wheels fall off lol
 

·
Registered
Joined
·
78 Posts
I appreciate the input guys, the plug didnt look lean eather, i guess ill throw the musari exhaust back on and just ride it till the wheels fall off lol
Are you still having issues with the pipe getting cherry? Mine is doing it now, I have an M4 exhaust and K&N Ru-1130 filter with a bazzaz zfi that I just installed. No matter what map I use it still gets red, I've tried riching it up to the point that performance suffers and it is still red....this is when sitting in the garage at idle though, I have yet to take it for a spin to cool it off and see if it still does this.
 

·
Super Moderator
Joined
·
1,851 Posts
Exhaust pipe thickness and Material type can differ from pipe to pipe manufacturer's therefore will show different results on the same bike at the same temp , I put a quick n easy temp gage on mine so i'll always know what the motor temp is which is the important thing
.
I had my temp at 257 degrees after 4 attempts at a steep hill and its the first time I smelt the motor (hot) ,but i didnt look down at the pipe . I will next time ;)
 

Attachments

·
Registered
Joined
·
564 Posts
What's happening at idle(0% throttle position) might be different than anything a Bazzaz or Power Commander can resolve with an air/fuel map. Idle is going to be the hottest condition this bike has. My advice is to avoid idling for too long.

It's just something we have to deal with until someone hacks the Z125 ECU and reworks all the emmisions crap that can't be resolved with an add-on tuner.

It might never happen. Niche bikes like this don't get a lot of attention from the regulars like Guhl, Ivan, ECU Unleashed, Flashtune and others.
 

·
Registered
Joined
·
78 Posts
What's happening at idle(0% throttle position) might be different than anything a Bazzaz or Power Commander can resolve with an air/fuel map. Idle is going to be the hottest condition this bike has. My advice is to avoid idling for too long.

It's just something we have to deal with until someone hacks the Z125 ECU and reworks all the emmisions crap that can't be resolved with an add-on tuner.

It might never happen. Niche bikes like this don't get a lot of attention from the regulars like Guhl, Ivan, ECU Unleashed, Flashtune and others.
Thanks for the advice!! I called the dealorship (which is a mom and pop shop, pretty nice) and they said I could bring it in and look at it but it may be there for about a week as they are busy. I removed the bazzaz and it still hunts. Do you think this could be a faulty oem ecu (just had it replaced from the recall) or bad stock 02 sensor? Basically wondering if I am wasting my time taking it in? It performs wonderfully through the gears, no pops on decel, plenty of power, just hunts at stop signs (makes me think i'm killing the poor thing!!!). Thanks again for your advice!!
 

·
Registered
Joined
·
78 Posts
What's happening at idle(0% throttle position) might be different than anything a Bazzaz or Power Commander can resolve with an air/fuel map. Idle is going to be the hottest condition this bike has. My advice is to avoid idling for too long.

It's just something we have to deal with until someone hacks the Z125 ECU and reworks all the emmisions crap that can't be resolved with an add-on tuner.

It might never happen. Niche bikes like this don't get a lot of attention from the regulars like Guhl, Ivan, ECU Unleashed, Flashtune and others.
Exhaust pipe thickness and Material type can differ from pipe to pipe manufacturer's therefore will show different results on the same bike at the same temp , I put a quick n easy temp gage on mine so i'll always know what the motor temp is which is the important thing
.
I had my temp at 257 degrees after 4 attempts at a steep hill and its the first time I smelt the motor (hot) ,but i didnt look down at the pipe . I will next time ;)
Thanks for the info, I will have to read my engine temp and see, I think you are right with the red pipe, just the nature of the beast. I'm really concerned with it hunting at stop signs when in gear, full clutch, 0% throttle (doesn't hunt in neutral just revs higher). Hunts from 2700-3100 rpm.
 

·
Super Moderator
Joined
·
1,851 Posts
3000 is what it will idle with the re-call :wink2:

.
mine a couple others here see 3000 on the tach !
 

Attachments

·
Registered
Joined
·
78 Posts
3000 is what it will idle with the re-call :wink2:

.
mine a couple others here see 3000 on the tach !
Yeah, I understand they bumped it up to 3000, but it hunts to get there, then goes back down to 2700, then up to 3100, then back down to 2700, sounds like a loop of somesort. And in neutral idles at 3800.
 

·
Registered
Joined
·
564 Posts
Do you think this could be a faulty oem ecu (just had it replaced from the recall) or bad stock 02 sensor? Basically wondering if I am wasting my time taking it in?
No, no and probably yes. I have to wonder if your throttle is twitching between 0% and 1%. Kinda linked to what I mentioned, there's a lot of different stuff going on between 0% and 1%. I'd say just let it go for a little while and see what happens. Likely nothing to worry about. Mine hunts like one or twice at startup, but then levels out at about 2200.
 

·
Super Moderator
Joined
·
1,851 Posts
Yeah, I understand they bumped it up to 3000, but it hunts to get there, then goes back down to 2700, then up to 3100, then back down to 2700, sounds like a loop of somesort. And in neutral idles at 3800.
.
Sorry, missed the 3800 rpm was on my out the door to sell one of my other bikes . thats over my head . wait a day or two and watch here or sounds like dealership time
.
Had my recall done and like 8bits it idles at 3k at start up , and then go's down to 2k ... not the 1750-1850 they state on the notice . but thats looking at the stock OD / on a real reader its probably set at the spec' ?
.
the service manger told me it will idle faster now so don't freak out
.
but also now my bike will idle at 3000 for before coming down to the 2000 for about 2-3 seconds after chopping the throttle off / even after its been fully warmed up ..but not all the time
.
good news is it hasn't stalled once sense the re-call :grin2:
 

·
Registered
Joined
·
44 Posts
Sounds like a vacuum leak or you you feul injection has some thing wrong with it. The red pipe at a stop is not a big deal but hunting idle is. If it was mine i would spray wd40 around the seal at head and throttle body if rpm changes thats it bad seal.if not to the dealer
 

·
Registered
Joined
·
78 Posts
Fixed!!

Sounds like a vacuum leak or you you feul injection has some thing wrong with it. The red pipe at a stop is not a big deal but hunting idle is. If it was mine i would spray wd40 around the seal at head and throttle body if rpm changes thats it bad seal.if not to the dealer

I took it to the dealer and found the throttle body to be defective. It was replaced under warranty. They also told me not to run any sort of hi flow air filter, even with the bazzaz fuel controller, or I would burn out my top end. I'm not sure if I believe that, but for now I have put the oem airbox back on.
 

·
Registered
Joined
·
78 Posts
Idle

3000 is what it will idle with the re-call :wink2:

.
mine a couple others here see 3000 on the tach !
Hey Kaw'ee, just an fyi, the dealership replaced my throttle bottle and now she idles just under 2000rpm with the re-call ecu installed! Not sure if this is something you want the dealer to look at or not but thought I would let you know!
 

·
Super Moderator
Joined
·
1,851 Posts
Thanks , Not sure how the under warranty works with me being the second owner ?
.
i'll see if it stays a problem then give them a call :mad:
.
 
1 - 20 of 20 Posts
Top