Kawasaki Z125 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I have a 2020 Z, and I never had this problem till today, I’ve got about 980ish miles on it, rode it fine today no problem, than i came home and I saw the check engine light was on, it doesn’t flash or anything, it just remains on. If anyone knows what’s up, please help out! Much appreciated.
 

·
Super Moderator
Joined
·
1,875 Posts
Get the codes and post them up here for one of us to help you out ;)


CEL DFI CODES.JPG
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
I don’t think there’s nothing wrong, I checked everything, made sure things were snug, idk if I should just ride it for a little to see if it goes away? But if not than I’ll do the diagnostic?
 

·
Super Moderator
Joined
·
1,875 Posts
CEL ERACING.jpg
 

·
Super Moderator
Joined
·
291 Posts
I don’t think there’s nothing wrong, I checked everything, made sure things were snug, idk if I should just ride it for a little to see if it goes away? But if not than I’ll do the diagnostic?
Whether you think anything is wrong or not fact of the matter is the light is on, which means there is something wrong. Whenever that light comes on you should do the diagnostic to see what the issue is. Can't fix the issue until we know what it is. Can't know what the issue is until you run the diagnostic. How do I know there's an issue? Light on = issue.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
Yo kawee the light just went off on it’s own today as I rode it, Right when I got home from today’s ride the light when I checked was gone. Wtf what does that mean
 

·
Super Moderator
Joined
·
1,875 Posts
That means something temporarily wasn't happy with your DFI system but not a permanent issue, and it cleared itself per my 2nd post. Or a overheat CEL seems to clear right away
But you missed the opportunity to avoid a possible problem that might leave you stranded or damage your engine later by not reading the CEL code. Always a good idea to get the code when they show
 

·
Registered
Joined
·
152 Posts
My bikes ecu light came on one time it was the 02 sensor had craped itself.
So I ordered a 02 optimiser from Kawasaki Brad never had a problem since.(y)
 

·
Registered
Joined
·
16 Posts
I need to check mine.. I’ve had a light on for about three weeks even though everything seems fine need to run the code and see what the actual issue was or is.
 
1 - 9 of 9 Posts
Top