Kawasaki Z125 Forum banner
1 - 20 of 53 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
I need clarification on a basic concept with a 143cc build. With the purchase of the BBK , an ARacer ECU, intake, tires, chain etc I didn't want to spend another $250-300.00 so I didn't purchase the AFI / o2 sensor. I was planning on getting it on a local Dyno for the tune. My confusion is how can I get it started and broken in to be able to get it on the Dyno, w/o a base map? Do I use the ARacer app to set up a general A/F ratio say (13.5), for the first start up and break in ?

All advice is appreciated.
 

·
Registered
2017 Z125 143BBK
Joined
·
34 Posts
I’m in almost the same boat as you. Waiting on my full 143 kit. Ordered the Aracer Mini5 as well and no wide and even though now I’m considering it. It’s almost plug and play. Probably cheaper and easier then dealing with dyno time.

4 posts down @Supermoto4444 did a decent little explanation in his way of it. Looks like we can change the “fuel base” which effects all areas of the map. Now, this isn’t directly causing AFR ratings to be exact but we can richen it up as we don’t want to be too lean.


 

·
Registered
Joined
·
25 Posts
I’m in almost the same boat as you. Waiting on my full 143 kit. Ordered the Aracer Mini5 as well and no wide and even though now I’m considering it. It’s almost plug and play. Probably cheaper and easier then dealing with dyno time.

4 posts down @Supermoto4444 did a decent little explanation in his way of it. Looks like we can change the “fuel base” which effects all areas of the map. Now, this isn’t directly causing AFR ratings to be exact but we can richen it up as we don’t want to be too lean.


I don't have a downloadable map, but these settings work well for my 2019 z125 Pro...SSP 138cc/59mm bore kit, DCR cam, Chimera intake, Yosh RS-2, aRacer ignition coil...also, < tip > Having HD clutch springs is an entirely different experience no matter what your displacement...KCMO, USA

Communication Device Font Screenshot Gadget Software Font Screenshot Software Number Multimedia Font Screenshot Technology Electronic device Number Product Communication Device Font Screenshot Gadget Rectangle Font Office equipment Parallel Screenshot
 

·
Registered
2017 Z125 143BBK
Joined
·
34 Posts
I don't have a downloadable map, but these settings work well for my 2019 z125 Pro...SSP 138cc/59mm bore kit, DCR cam, Chimera intake, Yosh RS-2, aRacer ignition coil...also, < tip > Having HD clutch springs is an entirely different experience no matter what your displacement...KCMO, USA

View attachment 26779 View attachment 26780 View attachment 26781 View attachment 26782 View attachment 26783
Word, thanks mate. I ended up ordering the Af1 as well. But I will probably rock your chart while I break the 143 kit in and then will connect the af1 after the motor is broke in to dial it in. Thanks!
 

·
Registered
2017 Z125 143BBK
Joined
·
34 Posts
One last question. Did you ever run the BBK with the stock clutch? One last thing I forgot to order…it’s on the way. But until then…
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #6 ·

·
Registered
Joined
·
45 Posts
Discussion Starter · #7 ·
One last question. Did you ever run the BBK with the stock clutch? One last thing I forgot to order…it’s on the way. But until then…
I just installed the HD clutch yesterday, A couple of tips - To hold the primary and secondary clutches when taking off or tightening the nuts on the shafts, use a rubber strap wrench OR cut a wedge shape piece from a hockey puck to wedge into the gears instead of a coin. When assembling, mate the gears of the primary and the gears on the clutch basket together as you slide them on there respective shafts. This will save you a lot of frustration and time.
 

·
Registered
2017 Z125 143BBK
Joined
·
34 Posts
I just installed the HD clutch yesterday, A couple of tips - To hold the primary and secondary clutches when taking off or tightening the nuts on the shafts, use a rubber strap wrench OR cut a wedge shape piece from a hockey puck to wedge into the gears instead of a coin. When assembling, mate the gears of the primary and the gears on the clutch basket together as you slide them on there respective shafts. This will save you a lot of frustration and time.
Sweet! Thanks
 

·
Super Moderator
Joined
·
2,091 Posts
One last question. Did you ever run the BBK with the stock clutch? One last thing I forgot to order…it’s on the way. But until then…
There's also a thread here on clutch install if you need it or haven't seen it yet
 

·
Registered
2017 Z125 143BBK
Joined
·
34 Posts
There's also a thread here on clutch install if you need it or haven't seen it yet
Awesome, I’ll be sure to save the link 👍 I appreciate the info
 

·
Registered
Joined
·
25 Posts
One last question. Did you ever run the BBK with the stock clutch? One last thing I forgot to order…it’s on the way. But until then…
I did...it sucked...definitely burning and bogging. Installed the HD clutch springs after everything else, last mod...no more stalling the bike, much better feel on take off and positive feel of power.
 

·
Registered
2017 Z125 143BBK
Joined
·
34 Posts
@Supermoto4444 got one of the bikes done and started! Sounds soooo good! When you first started your bike do you remember your AFR’s? Currently idling at around 11.9 which is way rich. I played with the Fuel Base adjustment a bit but didn’t really change much. I’m glad it’s a bit too rich than lean but would like a 12.5-13 idle if possible. Thanks mate
 

·
Registered
2017 Z125 143BBK
Joined
·
34 Posts
Watched a HardRacing video where he walks through the initial setup. Looks like I need to get back into my fuel base and keep playing with it. Would like to set it up at around 12.5-13 to do a little break in run and then turn my auto tune to get a map generated. Had to play with the idle screw a bit on the throttle body as well and reset the TPS back to “0” as well. Fires up instantly now and idles well. Need to bring it up a bit as it’s idling around 1700.
 

·
Registered
Joined
·
25 Posts
@Supermoto4444 got one of the bikes done and started! Sounds soooo good! When you first started your bike do you remember your AFR’s? Currently idling at around 11.9 which is way rich. I played with the Fuel Base adjustment a bit but didn’t really change much. I’m glad it’s a bit too rich than lean but would like a 12.5-13 idle if possible. Thanks mate
Sweet! Great job! I use these AFR settings on my BBK / SSP-G 138cc/59mm piston. Press the cell you want to change..change it..press up arrow to send to ECU. Turn off the bike for at least 10 seconds...turn back on and start.
Font Technology Screenshot Number Machine
 

·
Registered
2017 Z125 143BBK
Joined
·
34 Posts
Sweet! Great job! I use these AFR settings on my BBK / SSP-G 138cc/59mm piston. Press the cell you want to change..change it..press up arrow to send to ECU. Turn off the bike for at least 10 seconds...turn back on and start.
View attachment 26798
Awesome thanks! That’s the one thing I dislike about this Aracer setup. You can’t physically tell what you’re running. For example, I have the AF1 hooked up. Been riding a lot with auto tune on. Get back home, turn off auto tune and it asks if I want to save which I confirm yes. Then turn the bike off. Next morning start it up and has a wonky idle and runs like garbage. Not every time, but did it this morning. So idk, maybe my map isn’t saving. I tried loading my saves too. The AFR sits exactly around 12.9-13.2 while riding. Plug is white. No tan or brown on it. What’s your plug like? Thanks again !
 

·
Registered
Joined
·
25 Posts
Watched a HardRacing video where he walks through the initial setup. Looks like I need to get back into my fuel base and keep playing with it. Would like to set it up at around 12.5-13 to do a little break in run and then turn my auto tune to get a map generated. Had to play with the idle screw a bit on the throttle body as well and reset the TPS back to “0” as well. Fires up instantly now and idles well. Need to bring it up a bit as it’s idling around 1700.
I like HardRacing, too...and Tommy Davis. I sent an AFR chart that I use (replied to last post)...change all cells to what the chart says and then send to ECU with UP arrow (bike does not have to be running, just on. This will be your starting point, right? Your BBK is 5cc bigger than mine so maybe richen or make slight changes, determined as you move fwd with your 143cc tuning.
Tire Wheel Fuel tank Plant Vehicle
Tire Wheel Fuel tank Vehicle Plant
 

·
Registered
Joined
·
25 Posts
Awesome thanks! That’s the one thing I dislike about this Aracer setup. You can’t physically tell what you’re running. For example, I have the AF1 hooked up. Been riding a lot with auto tune on. Get back home, turn off auto tune and it asks if I want to save which I confirm yes. Then turn the bike off. Next morning start it up and has a wonky idle and runs like garbage. Not every time, but did it this morning. So idk, maybe my map isn’t saving. I tried loading my saves too. The AFR sits exactly around 12.9-13.2 while riding. Plug is white. No tan or brown on it. What’s your plug like? Thanks again !
It's tan from running 4k miles or so. If you don't smell gas (rich) or if it doesn't bog or feel weak (lean)...then you are over the target and the AF1 will fine tune it.
 

·
Registered
2017 Z125 143BBK
Joined
·
34 Posts
It's tan from running 4k miles or so. If you don't smell gas (rich) or if it doesn't bog or feel weak (lean)...then you are over the target and the AF1 will fine tune it.
Ok, I haven’t done the up arrow to send it. I did richen across the board a bit to slightly over 100 so I’ll try that but when I go back it’s back to 100 again.
Great looking ride. I dig the red pop!
 
1 - 20 of 53 Posts
Top