Check engine light issue solved - Page 3 - Kawasaki Z125 Forum
 10Likes
Reply
 
LinkBack Thread Tools
post #21 of 24 (permalink) Old 09-09-2019, 04:11 PM
Senior Member
 
Kaw'ee's Avatar
 
Join Date: Dec 2017
Posts: 1,587
Garage
Quote:
Originally Posted by bizmoto View Post
how can i get one?
On his website
https://kawasakibrad.com/shop?olsPag...-sensor-bypass
.
.
Kawasaki Brad likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kaw'ee
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kaw'ee is online now  
post #22 of 24 (permalink) Old 09-23-2019, 06:48 PM
Senior Member
 
Kawasaki Brad's Avatar
 
Join Date: Feb 2017
Location: Stony Plain (West of Edmonton, Alberta, Canada)
Posts: 168
Garage
https://youtu.be/OqV9uFUt_dg
Squeaky Huevos did a pretty good job of explaining why we need an O2 bypass in his vid.

Thanks for the mention Squeaky (Not sure if you're a member of the forum)

Anything can kill you. Pick something fun.
kawasakibrad.com
Youtube Channel:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kawasaki Brad is offline  
post #23 of 24 (permalink) Old 09-26-2019, 02:39 PM
Senior Member
 
Kaw'ee's Avatar
 
Join Date: Dec 2017
Posts: 1,587
Garage
Quote:
Originally Posted by Kawasaki Brad View Post
Kaw'ee, yours is in the mail because even though I didn't order from the sites you recommended they did help in tracking down the part number.
Thanks Brad, just got home today from my annual 3 days down the Colorado river trip (off topic pic below) and picked up my o2 optimizer.

I need something new to do with the Z' so I'm going to throw the DFI back on and test the using the o2 optimizer VS just unplugging the stock o2 like i had
Should get rid of the CEL light and the slight lean condition at 1/4 throttle i had.
.
Attached Thumbnails
Click image for larger version

Name:	COBRA 6.jpg
Views:	8
Size:	181.5 KB
ID:	23875  
Kawasaki Brad likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kaw'ee
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kaw'ee is online now  
 
post #24 of 24 (permalink) Old 09-26-2019, 05:13 PM
Senior Member
 
Azlar49's Avatar
 
Join Date: May 2019
Posts: 117
Garage
Quote:
Originally Posted by Kaw'ee View Post
Thanks Brad, just got home today from my annual 3 days down the Colorado river trip (off topic pic below) and picked up my o2 optimizer.

I need something new to do with the Z' so I'm going to throw the DFI back on and test the using the o2 optimizer VS just unplugging the stock o2 like i had
Should get rid of the CEL light and the slight lean condition at 1/4 throttle i had.
.
Definitely lean so having the O2 is a good start. FYI it took over 70 miles between track day and races for my light to go away so you might have the same. However my ontrack sessions are never more than 20 minutes at a time so that could also be why since the manual does say run it for more than 30 minutes.

Ride Safe
Azlar49 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome