LED turn signals won't flash.. - Kawasaki Z125 Forum
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 01-19-2017, 06:05 PM Thread Starter
Member
 
dodge's Avatar
 
Join Date: Jul 2016
Location: Aggieland
Posts: 89
LED turn signals won't flash..

Installed an adjustable relay and the fronts were working OK. After installing the rear leds, they all come on, but will not flash. Fuses check out ok.
dodge is offline  
post #2 of 9 (permalink) Old 06-10-2017, 04:53 PM
Junior Member
 
Join Date: May 2017
Posts: 13
what adjustable relay?
Only one Ive found that works is the one from TST
cwadej is offline  
post #3 of 9 (permalink) Old 06-11-2017, 03:42 PM
Junior Member
 
Join Date: May 2017
Location: Bay Area, CA
Posts: 9
Quote:
Originally Posted by cwadej View Post
what adjustable relay?
Only one Ive found that works is the one from TST
Since this thread has been dead since January and OP never got a response I thought I might add my experience.


I purchased a adjustable unit from amazon and it works. I followed the TST video and unpinned the Orange wire on the harness next to the steering column behind the headlight. After I unpinned I cut off the stock clips and put female spade connectors on, so I can plug it straight onto the relay I purchased off amazon.

Because I am new I can't link yet but if you search "AUDEW 2-Pin Electronic Turn Signal Flasher Relay Fix Motorcycle Turn Signal Hyper Flash" it is the orange one.
cvwrx is offline  
 
post #4 of 9 (permalink) Old 06-11-2017, 04:26 PM
Member
 
Join Date: Apr 2017
Location: Palmer, MA
Posts: 73
TwelveGaugeSage is offline  
post #5 of 9 (permalink) Old 06-13-2017, 07:07 PM
Junior Member
 
Join Date: May 2017
Posts: 13
I ordered that exact one. Also did the orange wire. Didnt work. That's crazy. Maybe I wasnt waiting long enough when adjusting the pot?
cwadej is offline  
post #6 of 9 (permalink) Old 06-14-2017, 10:05 PM
Junior Member
 
Join Date: May 2017
Location: Bay Area, CA
Posts: 9
Quote:
Originally Posted by cwadej View Post
I ordered that exact one. Also did the orange wire. Didnt work. That's crazy. Maybe I wasnt waiting long enough when adjusting the pot?
What's happening when you adjust it? Do they blink or turn on at all?
cvwrx is offline  
post #7 of 9 (permalink) Old 06-15-2017, 08:26 PM
Junior Member
 
Join Date: May 2017
Posts: 13
no blink. I'll try it this weekend and try slower.
cwadej is offline  
post #8 of 9 (permalink) Old 06-16-2017, 12:51 PM
Junior Member
 
Join Date: May 2017
Location: Bay Area, CA
Posts: 9
Quote:
Originally Posted by cwadej View Post
no blink. I'll try it this weekend and try slower.
I don't think it matters but have you switched how you have the wires connected to your relay.
cvwrx is offline  
post #9 of 9 (permalink) Old 06-17-2017, 06:11 PM
Junior Member
 
Join Date: May 2017
Posts: 13
Quote:
Originally Posted by cvwrx View Post
I don't think it matters but have you switched how you have the wires connected to your relay.

i did not. havent gotten out there to diagnose, as it's not a priority this weekend.
cwadej is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible to convert tail light to also be turn signals? Elektrey Kawasaki Z125 General Discussion 7 11-18-2016 03:47 PM
LED TURN SIGNALS for the Z125 Pro HardRacing Hardracing 0 07-26-2016 04:01 PM
LED Front Turn Signals faizteuku Kawasaki Z125 General Discussion 17 07-14-2016 01:30 PM
LED Tail Light with Integrated Turn Signals - IN STOCK HardRacing Hardracing 0 06-30-2016 04:34 PM
HD Relay Install for Z125 so your LED Signals work correctly HardRacing Hardracing 2 06-16-2016 05:38 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Optimization by vBSEO 3.6.1 ©2011, Crawlability, Inc.